package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#define (Facility\w*)\s+%%%\s+(\w+)\s+\d+`)
var str = `#define FacilityUsermodeHypervisor %%% FACILITY_USERMODE_HYPERVISOR 53
#define FACILITY_USERMODE_HYPERVISOR tty`
var substitution = "z$1 = $2,"
fmt.Println(re.ReplaceAllString(str, substitution))
}