using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#define (Facility\w*)\s+%%%\s+(\w+)\s+\d+";
string substitution = @"z$1 = $2,";
string input = @"#define FacilityUsermodeHypervisor %%% FACILITY_USERMODE_HYPERVISOR 53
#define FACILITY_USERMODE_HYPERVISOR tty";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}