// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"#define (Facility\w*)\s+%%%\s+(\w+)\s+\d+").unwrap();
let string = "#define FacilityUsermodeHypervisor %%% FACILITY_USERMODE_HYPERVISOR 53
#define FACILITY_USERMODE_HYPERVISOR tty";
let substitution = "z$1 = $2,";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}