#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "#define (Facility\w*)\s+%%%\s+(\w+)\s+\d+"
Local $sString = "#define FacilityUsermodeHypervisor %%% FACILITY_USERMODE_HYPERVISOR 53" & @CRLF & _
"#define FACILITY_USERMODE_HYPERVISOR tty"
Local $sSubst = "z$1 = $2,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)