re = /#define (Facility\w*)\s+%%%\s+(\w+)\s+\d+/
str = '#define FacilityUsermodeHypervisor %%% FACILITY_USERMODE_HYPERVISOR 53
#define FACILITY_USERMODE_HYPERVISOR tty'
subst = 'z$1 = $2,'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result