# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"#define (Facility\w*)\s+%%%\s+(\w+)\s+\d+"
test_str = ("#define FacilityUsermodeHypervisor %%% FACILITY_USERMODE_HYPERVISOR 53\n"
"#define FACILITY_USERMODE_HYPERVISOR tty")
subst = "z$1 = $2,"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.