$re = '/#define (Facility\w*)\s+%%%\s+(\w+)\s+\d+/';
$str = '#define FacilityUsermodeHypervisor %%% FACILITY_USERMODE_HYPERVISOR 53
#define FACILITY_USERMODE_HYPERVISOR tty';
$subst = "z$1 = $2,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;