# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w*\.?)(?:guestofaguest\.)(\w*)/guestofaguest.com/g;t' <<< " http://admin.guestofaguest.com/
http://dc.guestofaguest.com/
http://dev.guestofaguest.com/
http://guestofaguest.com/
http://hamptons.guestofaguest.com/
http://la.guestofaguest.com/
http://www.guestofaguest.com/"