package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w*\.?)(?:guestofaguest\.)(\w*)`)
var str = ` http://admin.guestofaguest.com/
http://dc.guestofaguest.com/
http://dev.guestofaguest.com/
http://guestofaguest.com/
http://hamptons.guestofaguest.com/
http://la.guestofaguest.com/
http://www.guestofaguest.com/`
var substitution = "guestofaguest.com"
fmt.Println(re.ReplaceAllString(str, substitution))
}