const regex = /(\w*\.?)(?:guestofaguest\.)(\w*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w*\\.?)(?:guestofaguest\\.)(\\w*)', 'g')
const str = ` http://admin.guestofaguest.com/
http://dc.guestofaguest.com/
http://dev.guestofaguest.com/
http://guestofaguest.com/
http://hamptons.guestofaguest.com/
http://la.guestofaguest.com/
http://www.guestofaguest.com/`;
const subst = `guestofaguest.com`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);