#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\w*\.?)(?:guestofaguest\.)(\w*)"
Local $sString = " http://admin.guestofaguest.com/" & @CRLF & _
" http://dc.guestofaguest.com/" & @CRLF & _
" http://dev.guestofaguest.com/" & @CRLF & _
" http://guestofaguest.com/" & @CRLF & _
" http://hamptons.guestofaguest.com/" & @CRLF & _
" http://la.guestofaguest.com/" & @CRLF & _
" http://www.guestofaguest.com/"
Local $sSubst = "guestofaguest.com"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)