re = /(\w*\.?)(?:guestofaguest\.)(\w*)/
str = ' http://admin.guestofaguest.com/
http://dc.guestofaguest.com/
http://dev.guestofaguest.com/
http://guestofaguest.com/
http://hamptons.guestofaguest.com/
http://la.guestofaguest.com/
http://www.guestofaguest.com/'
subst = 'guestofaguest.com'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result