use strict;
my $str = ' http://admin.guestofaguest.com/
http://dc.guestofaguest.com/
http://dev.guestofaguest.com/
http://guestofaguest.com/
http://hamptons.guestofaguest.com/
http://la.guestofaguest.com/
http://www.guestofaguest.com/';
my $regex = qr/(\w*\.?)(?:guestofaguest\.)(\w*)/p;
my $subst = 'guestofaguest.com';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";