import re
regex = re.compile(r"(\w*\.?)(?:guestofaguest\.)(\w*)")
test_str = (" http://admin.guestofaguest.com/\n"
" http://dc.guestofaguest.com/\n"
" http://dev.guestofaguest.com/\n"
" http://guestofaguest.com/\n"
" http://hamptons.guestofaguest.com/\n"
" http://la.guestofaguest.com/\n"
" http://www.guestofaguest.com/")
subst = "guestofaguest.com"
result = regex.sub(subst, test_str)
if result:
print(result)