# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("[^"]*"),"[^"]*","[^"]*"(,"[^"]*")/$1$2/gm;t' <<< "\"1234\",\"1234\",\"S243\",\"Text\"
\"1234\",\"1234\",\"01A243\",\"other Text\""