use strict;
my $str = '"1234","1234","S243","Text"
"1234","1234","01A243","other Text"';
my $regex = qr/("[^"]*"),"[^"]*","[^"]*"(,"[^"]*")/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";