import Foundation
let pattern = #"("[^"]*"),"[^"]*","[^"]*"(,"[^"]*")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"1234","1234","S243","Text"
"1234","1234","01A243","other Text"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)