$re = '/("[^"]*"),"[^"]*","[^"]*"(,"[^"]*")/m';
$str = '"1234","1234","S243","Text"
"1234","1234","01A243","other Text"';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;