using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""[^""]*""),""[^""]*"",""[^""]*""(,""[^""]*"")";
string substitution = @"$1$2";
string input = @"""1234"",""1234"",""S243"",""Text""
""1234"",""1234"",""01A243"",""other Text""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}