import re
regex = re.compile(r"(\"[^\"]*\"),\"[^\"]*\",\"[^\"]*\"(,\"[^\"]*\")", flags=re.MULTILINE)
test_str = ("\"1234\",\"1234\",\"S243\",\"Text\"\n"
"\"1234\",\"1234\",\"01A243\",\"other Text\"")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)