const regex = /span>.*?(game).*?<\/span/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('span>.*?(game).*?<\\\/span', 'i')
const str = `<div class="fsearchp">
<p><a href="/5278-bams-bad-ass-game-show.html" title="Перейти на страницу сериала «Bam's Bad Ass Game Show»">Bam's Bad Ass Game Show</a> (2014 - ...)
<span>(Bam's Bad Ass Game Show)</span>
</p>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}