import Foundation
let pattern = #"span>.*?(game).*?<\/span"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<div class="fsearchp">
<p><a href="/5278-bams-bad-ass-game-show.html" title="Перейти на страницу сериала «Bam's Bad Ass Game Show»">Bam's Bad Ass Game Show</a> (2014 - ...)
<span>(Bam's Bad Ass Game Show)</span>
</p>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}