// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)span>.*?(game).*?<\/span").unwrap();
let string = "<div class=\"fsearchp\">
<p><a href=\"/5278-bams-bad-ass-game-show.html\" title=\"Перейти на страницу сериала «Bam's Bad Ass Game Show»\">Bam's Bad Ass Game Show</a> (2014 - ...)
<span>(Bam's Bad Ass Game Show)</span>
</p>
</div>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}