use strict;
my $str = '<div class="fsearchp">
<p><a href="/5278-bams-bad-ass-game-show.html" title="Перейти на страницу сериала «Bam\'s Bad Ass Game Show»">Bam\'s Bad Ass Game Show</a> (2014 - ...)
<span>(Bam\'s Bad Ass Game Show)</span>
</p>
</div>';
my $regex = qr/span>.*?(game).*?<\/span/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}