re = /span>.*?(game).*?<\/span/i
str = '<div class="fsearchp">
<p><a href="/5278-bams-bad-ass-game-show.html" title="Перейти на страницу сериала «Bam\'s Bad Ass Game Show»">Bam\'s Bad Ass Game Show</a> (2014 - ...)
<span>(Bam\'s Bad Ass Game Show)</span>
</p>
</div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end