#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<div\sid=\"[^\"]{0,}_original_[^\"]{0,}\".*?<\/div>"
Local $sString = " <div id="po_comment_79739738">" & @CRLF & _
" какой-то текст" & @CRLF & _
" </div>" & @CRLF & _
" <div id="po_comment_original_79739738" style="display:none;">" & @CRLF & _
" какой-то текст" & @CRLF & _
" </div>" & @CRLF & _
" <div id="po_comment_79739738">" & @CRLF & _
" какой-то текст" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")