const regex = /<div\sid=\"[^\"]{0,}_original_[^\"]{0,}\".*?<\/div>/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div\\sid=\\"[^\\"]{0,}_original_[^\\"]{0,}\\".*?<\\\/div>', 'gms')
const str = ` <div id="po_comment_79739738">
какой-то текст
</div>
<div id="po_comment_original_79739738" style="display:none;">
какой-то текст
</div>
<div id="po_comment_79739738">
какой-то текст
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}