use strict;
my $str = ' <div id="po_comment_79739738">
какой-то текст
</div>
<div id="po_comment_original_79739738" style="display:none;">
какой-то текст
</div>
<div id="po_comment_79739738">
какой-то текст
</div>';
my $regex = qr/<div\sid=\"[^\"]{0,}_original_[^\"]{0,}\".*?<\/div>/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}