using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div\sid=\""[^\""]{0,}_original_[^\""]{0,}\"".*?<\/div>";
string input = @" <div id=""po_comment_79739738"">
какой-то текст
</div>
<div id=""po_comment_original_79739738"" style=""display:none;"">
какой-то текст
</div>
<div id=""po_comment_79739738"">
какой-то текст
</div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}