import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div\\sid=\\\"[^\\\"]{0,}_original_[^\\\"]{0,}\\\".*?<\\/div>";
final String string = " <div id=\"po_comment_79739738\">\n"
+ " какой-то текст\n"
+ " </div>\n"
+ " <div id=\"po_comment_original_79739738\" style=\"display:none;\">\n"
+ " какой-то текст\n"
+ " </div>\n"
+ " <div id=\"po_comment_79739738\">\n"
+ " какой-то текст\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}