// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ms)<div\sid=\"[^\"]{0,}_original_[^\"]{0,}\".*?<\/div>"#).unwrap();
let string = " <div id=\"po_comment_79739738\">
какой-то текст
</div>
<div id=\"po_comment_original_79739738\" style=\"display:none;\">
какой-то текст
</div>
<div id=\"po_comment_79739738\">
какой-то текст
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}