re = /<div\sid=\"[^\"]{0,}_original_[^\"]{0,}\".*?<\/div>/m
str = ' <div id="po_comment_79739738">
какой-то текст
</div>
<div id="po_comment_original_79739738" style="display:none;">
какой-то текст
</div>
<div id="po_comment_79739738">
какой-то текст
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end