$re = '/<div\sid=\"[^\"]{0,}_original_[^\"]{0,}\".*?<\/div>/ms';
$str = ' <div id="po_comment_79739738">
какой-то текст
</div>
<div id="po_comment_original_79739738" style="display:none;">
какой-то текст
</div>
<div id="po_comment_79739738">
какой-то текст
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);