package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)<div\sid=\"[^\"]{0,}_original_[^\"]{0,}\".*?<\/div>`)
var str = ` <div id="po_comment_79739738">
какой-то текст
</div>
<div id="po_comment_original_79739738" style="display:none;">
какой-то текст
</div>
<div id="po_comment_79739738">
какой-то текст
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}