# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*([a-zA-Z]).*\s+([a-zA-Z])\S+$/\U$1$2/gm;t' <<< "a A BCD eFG"