import Foundation
let pattern = #"^\s*([a-zA-Z]).*\s+([a-zA-Z])\S+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"a A BCD eFG"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\U$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)