using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*([a-zA-Z]).*\s+([a-zA-Z])\S+$";
string substitution = @"\U$1$2";
string input = @"a A BCD eFG";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}