const regex = /^\s*([a-zA-Z]).*\s+([a-zA-Z])\S+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*([a-zA-Z]).*\\s+([a-zA-Z])\\S+$', 'gm')
const str = `a A BCD eFG`;
const subst = `\U$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);