import re
regex = re.compile(r"^\s*([a-zA-Z]).*\s+([a-zA-Z])\S+$", flags=re.MULTILINE)
test_str = "a A BCD eFG"
subst = "\\U$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)