$re = '/^\s*([a-zA-Z]).*\s+([a-zA-Z])\S+$/m';
$str = 'a A BCD eFG';
$subst = "\U$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;