# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(instagram|ig)\s*[:-]\s*\K([\w.]+)\b/<a href="$1">$1<\/a>/g;t' <<< "instagram - myigusername93
ig: myigusername93"