$re = '/\b(instagram|ig)\s*[:-]\s*\K([\w.]+)\b/';
$str = 'instagram - myigusername93
ig: myigusername93';
$subst = "<a href=\"$1\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;