re = /\b(instagram|ig)\s*[:-]\s*\K([\w.]+)\b/
str = 'instagram - myigusername93
ig: myigusername93'
subst = '<a href="$1">$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result