using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(instagram|ig)\s*[:-]\s*\K([\w.]+)\b";
string substitution = @"<a href=""$1"">$1</a>";
string input = @"instagram - myigusername93
ig: myigusername93";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}