const regex = /\b(instagram|ig)\s*[:-]\s*\K([\w.]+)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(instagram|ig)\\s*[:-]\\s*\\K([\\w.]+)\\b', 'g')
const str = `instagram - myigusername93
ig: myigusername93`;
const subst = `<a href="$1">$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);