use strict;
my $str = 'instagram - myigusername93
ig: myigusername93';
my $regex = qr/\b(instagram|ig)\s*[:-]\s*\K([\w.]+)\b/p;
my $subst = '<a href="$1">$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";