import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(instagram|ig)\\s*[:-]\\s*\\K([\\w.]+)\\b";
final String string = "instagram - myigusername93\n"
+ "ig: myigusername93";
final String subst = "<a href=\"$1\">$1</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}