import re
regex = re.compile(r"\b(instagram|ig)\s*[:-]\s*\K([\w.]+)\b")
test_str = ("instagram - myigusername93\n"
"ig: myigusername93")
subst = "<a href=\"$1\">$1</a>"
result = regex.sub(subst, test_str)
if result:
print(result)