#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<img src=\".+?\/PIAimages\/(.+)\""
Local $sString = "<img src="www.ikea.com/ms/img/header/logo.gif" >" & @CRLF & _
"<img src="www.ikea.com/ms/ru_RU/img/ads/askanna.jpg" >" & @CRLF & _
"<img src="www.ikea.com/ms/img/header/main_menu_shadow.gif" >" & @CRLF & _
"<img src="www.ikea.com/ms/media/seorange/20153/20151_dica04a..." >" & @CRLF & _
"<img src="www.ikea.com/PIAimages/0322782_PE516321_S3.JPG" >" & @CRLF & _
"<img src="www.ikea.com/PIAimages/0355650_PE547817_S3.JPG" >" & @CRLF & _
"www.ikea.com/PIAimages/0292760_PE425390_S3.JPG" >" & @CRLF & _
"www.ikea.com/PIAimages/0325067_PE523174_S3.JPG" >"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")