// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<img src=\".+?\/PIAimages\/(.+)\""#).unwrap();
let string = "<img src=\"www.ikea.com/ms/img/header/logo.gif\" >
<img src=\"www.ikea.com/ms/ru_RU/img/ads/askanna.jpg\" >
<img src=\"www.ikea.com/ms/img/header/main_menu_shadow.gif\" >
<img src=\"www.ikea.com/ms/media/seorange/20153/20151_dica04a...\" >
<img src=\"www.ikea.com/PIAimages/0322782_PE516321_S3.JPG\" >
<img src=\"www.ikea.com/PIAimages/0355650_PE547817_S3.JPG\" >
www.ikea.com/PIAimages/0292760_PE425390_S3.JPG\" >
www.ikea.com/PIAimages/0325067_PE523174_S3.JPG\" >";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}